The OPML (podcast subscription) import fails. What can I do?

uPod allows you to import podcast subscriptions from your previous podcast client using an OPML file (see this article for more details on adding subscriptions). uPod does it's best to be tolerant and tries to understand even invalid OPML files as generated by some podcast clients. But in some rare cases or when you are trying to import a non-OPML file, uPod will fail with an error message. In these cases try the following:
  1. Ensure that the file is really an OPML file. You can do so by opening the file in a text editor. It should start with something like
    <?xml version="1.0" encoding="UTF-8"?>
    <opml version="2.0">
    The important stuff here are the xml and the opml tag.
  2. If you are sure it is a valid OPML file, please and attach the problematic OPML file.

Feedback and Knowledge Base